DragonFly 3.8 released


The 3.8 release of DragonFly is out!  See the release page for a changelog and check your local mirror for download first.

Binary dports packages for 3.8 have been built; they are available for download.  (link goes to release versions of the packages.  Future updates will be in ../LATEST)

For upgrades from 3.6: You can pull the 3.8 source normally with git:

cd /usr/src
git fetch origin
git branch DragonFly_RELEASE_3_8 origin/DragonFly_RELEASE_3_8
git checkout DragonFly_RELEASE_3_8

Assuming you are using an unmodified kernel, here’s the steps I usually do for an upgrade:

# make buildworld && make buildkernel && make installkernel && make installworld && make upgrade

After upgrading from 3.6, pkg (as designed) will download the appropriate 3.8 packages with pkg upgrade.

Posted by     Categories: DragonFly, Goings-on, Heads Up!     9 Comments
9 Comments on DragonFly 3.8 released

Respond | Trackback

  1. Anonymous says:

    The main page doesn’t announce 3.8. Pkg will likely have a conflict, if you have heimdal or certain other packages, you’ll need to delete them and then try to upgrade again. For the makes followed by build, you should add -j (number of your processesors +1).

  2. John says:

    -j numbers are the default.

    E.g. ports will build with -j4 on 4-core machines, assuming the port is not marked jobs unsafe.

    In other words, no, you don’t need to add “-jX”

  3. Francois Tigeot says:

    I don’t think the previous poster was talking about ports builds here

  4. joris says:

    Also, don’t add -j to make installword. It might be broken (at least it is for me), due to recent changes.

  5. foo says:

    I’m just wondering what is the proper name of the project: is it DragonFly or DragonFly BSD. If its name is DragonFly BSD, why is “BSD” missing from the title. I remember the very early times when it was called “DragonFly BSD”, but recently you stopped calling it like earlier.

  6. In general, call it “DragonFly”. In a context where it’s important to label it as an operating system or as part of the BSD ‘family’, call it “DragonFlyBSD”. If you hate typing, call it ‘dfly’.

  7. foo says:

    @Justin Sherrill

    Thanks for the clarification.

  8. I came really close to using Dragonfly on my new work desktop. I wanted a modern filesystem and Hammer seemed best. Unfortunately there are programs I need to run for which only linux binaries exist (obscure non-opensource bioinformatics tools) and the Dragonfly linuxulator on amd64 apparently doesn’t work. FreeBSD’s does I believe (32-bit linux on 64-bit Freebsd which would be good enough) but, after much agonising, I decided to stick with linux (ubuntu) and use zfs.

    But I admit the other factor against Dragonfly was that Matt Dillon, after writing a filesystem that on paper is far superior to anything else out there, decided not to push it further and instead spend a few years writing its incompatible successor Hammer2. I need stability and so, I expect, do most users. Dragonfly is an awesome research project but I don’t do research on operating systems… A pity, because the world needs Hammer — and if someone could manage a Linux port I think it would be snapped up (given that it doesn’t suffer the licensing problems of ZFS and, unlike Btrfs, has proved its stability).

    My hope is Matt knows what he’s doing and Hammer2 will be so ultra-awesome that everyone will rush to port it…

  9. Wojtek says:

    Hammer1 is already best filesystem with history. Add swapcache and it’s a wonder.
    ANYTHING like virtualbox or qemu-kvm is missing. I need this as i always run few small VMs on production servers in my clients location.

    ZFS is a joke. i use UFS under FreeBSD

Respond

Comments

Comments