Using gcc 4.7 and pkgsrc


If you were thinking you wanted to try gcc 4.7 with pkgsrc, John Marino’s described the option you need to set.  It only works in pkgsrc-master  right now (because of changes John made), and not every package in pkgsrc will build.

The advantage is that it’s also possible, with the same syntax, to set pkgsrc to build with gcc 4.4.  This means the default compiler in DragonFly can be changed to gcc 4.7 and pkgsrc packages that aren’t compatible can still be built.

Update: Check this minor change: ‘?=’ instead of ‘=’.

Posted by     Categories: DragonFly, Goings-on, pkgsrc     0 Comments
0 Comments on Using gcc 4.7 and pkgsrc

Respond | Trackback

Respond

Comments

Comments