gcc 4.4 now default


Sascha Wildner has changed the default compiler to gcc 4.4.  See his commit notes for some details.  To my knowledge, we’re the only BSD using this recent a version.

A full buildworld/buildkernel is probably the best strategy.  I’ll be rebuilding all the pkgsrc packages for 2.9 using gcc 4.4…  This will take at least a week.

Posted by     Categories: Committed Code, DragonFly, Heads Up!     3 Comments
3 Comments on gcc 4.4 now default

Respond | Trackback

  1. Petr says:

    Does anyone know how many pkgsrc packages will be affected by this?

  2. Sascha Wildner says:

    Bulk builds are running by now, I believe. It will take some days.

    I did see some issues due to packages using -Werror and gcc 4.4 spewing new warnings.

  3. I have 3 builds going now – DragonFly 2.9/i386/pkgsrc-2010Q4, 2.9/x86_64/pkgsrc-2010Q4, and DragonFly 2.9/x86_64/pkgsrc-current. My guess is that it’ll be some number of packages, but not catastrophic, and not bad to fix.

    If you’re on 2.8, it won’t affect you at all.

Respond

Comments

Comments