Quick fix for pkgin


If you’re using pkgin for managing pkgsrc packages, there’s a new bugfix to cover scenarios where there’s an old and new version dependency on the same item, like php between versions 5.2 and 5.3.  It’s described in French, or translated English.  (Thanks, Antonio Huete)

Posted by     Categories: DragonFly, Goings-on, pkgsrc     2 Comments
2 Comments on Quick fix for pkgin

Respond | Trackback

  1. iMil says:

    Thanks for the news guys !

    Just a quick update, and an (almost) plain english explanation :

    pkgin 0.3.3.3 is on its way, along with the “double dewey match fix” (foo>=1.2.3<2.0), i've corrected another issue dealing with unnecessary package being tagged as "to-remove" when they already are on the upgrade list. I am quite confident that those fixes actually end any dependency problem that could have happened in the past.

    While at it, i've included a mechanism that will handle a case i've been through: if by any chance a package is no more on the repository, pkgin will try to satisfy it's dependencies with local dependencies, and try to keep this non-upgradable package.

    Now about the future. I will branch pkgin 0.4 anytime soon now. It will include three major changes:

    . No SQLite dependency anymore (that's gonna end up some massive trolling i guess)
    . Performance improvements thanks to bapt's 0-copy patches
    . Better MINIX integration

    Thanks for using pkgin and keep the tests going !

  2. [...] j’ai corrigé plusieurs bugs dans pkgin, comme vous l’avez peut-être lu ici ou là. Ces fixes devraient marquer la fin de la branche 0.3, actuellement disponible dans pkgsrc, et je [...]

Respond

Comments

Comments