pkg_radd improvments


If you’re on DragonFly 2.3.1 or 2.3.2: I’ve uploaded a full pkgsrc build to avalon.dragonflybsd.org based on pkgsrc-2009Q2.  It’s possible to use pkg_radd to automatically download and install packages for those systems.  (and pkg_search will search the remote repository for you.)

If you’re on DragonFly 2.2.x, I’ve modified the pkg_radd target for that release so that when pkg_radd makes a request, it is redirected to the appropriate place on avalon.dragonflybsd.org instead of attempting (and potentially failing) to find a matching mirror.

I said close to the same thing as the above text on users@; the short form of all this is that pkg_radd should generally work for everyone.  Tell me if that’s not your experience.

Posted by     Categories: DragonFly, pkgsrc     3 Comments
3 Comments on pkg_radd improvments

Respond | Trackback

  1. crash says:

    Very nice to hear :P great work guys, i will test that out

  2. crash says:

    Hmm i’m running devel 2.3.2 now is pkg_radd auto download from avalon pkgsrcQ2 or does i need to set that up in a conf file?

    and my other question is can i upgrade packages with pkg_radd when a new Quarter release is out?

  3. Justin says:

    It’ll do 2009Q2 now, since it’s symlinked to as ‘stable’.

    I haven’t tried upgradign with pkg_radd – you will want to check avalon.dragonflybsd.org/packages and make sure that a new set of packages has actually been built, first. It takes about a week to build them all in the best of circumstances.

Respond

Comments

Comments