AMD64 progress update


The in-progress code for the Summer of Code project ‘DragonFly on AMD64′ has been imported; you can now build for SMP on AMD64, and complete a installworld/buildworld, natively.  Modules don’t (yet) compile…

5 Comments on AMD64 progress update

Respond | Trackback

  1. Roger Sistla says:

    Does this mean that an AMD64 port/iso will be released in September ?

    /RS

  2. Great job!
    Huge thanks to Jordan :-)

    AMD64 support is one of the two features missing before I install it on the rest of my boxes. The other would be support for hard disk encryption, but I guess there are many other much more important things to do in HAMMER.

  3. Robin Carey says:

    If you’re interested in Hard Disk Encryption, you should check out my Caesarion-v12 software:

    http://www.leopard.uk.com/cion

    It has a new type of encryption (which I invented) which as far as I’m aware has never been done before, and therefore breaks new ground in terms of cryptography.

    If Hammer was to support hard disk encryption, I would recommend it uses Cipher-Packet as found in Caesarion-V12.

    Cheers!

  4. Looks really nice.

    While I understand your concerns and why you added the “terrorism, paedophilia or crimes against humanity” part I ask you to change back to the original license. First of all these things are illegal anyway, you don’t need to make this part of your license. I guess no terrorist would really care about this anyway. I’m also not sure if this part of the license is even of relevance in the law. If the software is used for such things it wouldn’t defend you and on the other side I’m not sure if a license can really forbid usage cases like this. I know a lot of licenses include “you are not allowed to do this or that”, but in many cases it’s forbidden by the law or has no relevance.

    Now the reason I care for it: To make it short it is not an OSI or FSF or otherwise widely used license. This makes it harder to be added to a linux distribution, pkgsrc or ports. In pkgsrc it would require an additional license because of this little addition and a lot of linux distributions wouldn’t allow it, because it’s not an OSI or FSF licensed software.

  5. Roger – I’m pretty sure AMD64 DragonFly will be available for 2.4. It may not support 32-bit binaries, and it probably won’t build as many packages out of pkgsrc, or other things may be missing, so don’t plan to run any production machines with it, if it does happen.

Respond

Comments

Comments